Port forward dengan dua gateway di mikrotik

 

port forward dua gatewayPort forward dengan dua gateway atau ISP supaya kita bisa akses perangkat  dari dua jalur yang berbeda. Berikut gambarannya :

  • IP internet 1 : 1.2.3.4/30 mikrotik ether1
  • IP internet 2 : 5.6.7.8/30 mikrotik ether2
  • LAN 192.168.1.1/30 mikrotik ether3
  • IP perangkat 192.168.1.2/30 dengan port 8080

Setting mikrotik :

IP address

/ip address add 
address=1.2.3.4/30 interface=ether1
address=5.6.7.8/30 interface=ether2
add address=192.168.1.1/30 interface=ether3

NAT

/ip fire nat 
add chain=dst-nat action=dst-nat in-interface=ether1 dst-address=1.2.3.4 protocol=tcp dst-port=8080 to-address=192.168.1.2
add chain=dst-nat action=dst-nat in-interface=ether2 dst-address=5.6.7.8 protocol=tcp dst-port=8080 to-address=192.168.1.2

Tandai semua koneksi

/ip firewall mangle
add chain=prerouting in-interface=ether1 action=mark-connection dst-address=1.2.3.4 protocol=tcp dst-port=8080 new-connection-mark=ether1-conn
add chain=prerouting in-interface=ether2 action=mark-connection dst-address=5.6.7.8 protocol=tcp dst-port=8080 new-connection-mark=ether2-conn 

Tandai jalur koneksi

/ip firewall mangle
add chain=prerouting in-interface=ether3 connection-mark=ether1-conn action=mark-routing new-routing-mark=jalur1
add chain=prerouting in-interface=ether3 connection-mark=ether2-conn action=mark-routing new-routing-mark=jalur2

Rute

/ip route
add dst-address=0.0.0.0/0 routing-mark=jalur1 gateway=1.2.3.3
add dst-address=0.0.0.0/0 routing-mark=jalur2 gateway=5.6.7.7
Advertisements

Mikrotik password recovery

Alat untuk recovery user/password mikrotik, download filenya di http://manio.skyboo.net/mikrotik/. Syarat utama kita harus punya file backupan perangkat mikrotik yang mau kita recover. Kebetulan saya pakai linux untuk OSnya dan sudah terinstal gcc compiler. Ekstrak file *.tar.bz2 hasil downloadan.

tar xvf mtpass-0.9.tar.bz2

compile

cd mtpass-0.9
make

Cara menggunakannya:

./mtpass file-backup-mikrotik.backup

berikut hasil tangkapan layar backup password mikrotik punya saya
mikrotik-recovery-password

Lebih lanjut bisa dibaca di link berikut :
http://manio.skyboo.net/mikrotik/

Mengirim email dari mikrotik – netwatch

Mengirim notifikasi dari mikrotik ke email ketika ada salah satu perangkat yang mati dan hidup lagi.

  • Setting server email untuk pengirim (misal memakai gmail)
/tool e-mail set address=173.194.70.108 port=587
from=user@gmail.com user=user@gmail.com password=password_email
  • Test mengirim email
/tool e-mail send to=user@yahoo.com subject="test email"
body="test send email test send email test send email" tls=yes
  • Buat monitoring dengan netwatch
/tool netwatch add host=192.168.2.1 interval=20s up-script=[/tool e-mail send to=user@yahoo.com subject="server UP" body="alhamdulillah serve
rnya sudah UP lagi.." tls=yes] down-script=[/tool e-mail send to=user@yahoo.com subject="server DOWN" body="siap siap telepon berdering .." tls=yes]

Port smtp default adalah 25 untuk gmail sendiri 587, untuk mengetahui IP address smtp server email kita bisa lakukan ping atau bisa kita cek dengan ketik di alamat browser, misal smtp.gmail.com.ipaddress.com.

referensi : http://wiki.mikrotik.com/wiki/Manual:Tools/Netwatch

Setting wireless Mikrotik RB411ah sebagai router AP

Ada koneksi internet sedikit yang mau saya bagi ke laptop dan telepon genggam (yang sudah ada fitur WiFInya), kebetulan ada RB411ah sama miniPCI yang masih nganggur ditambah horn kenbotong 24 (seharusnya sudah ‘kelaut ajeh !’). Berikut Gambarnya :
ngeri
Satu lagi ūüėõ
Serem

Langsung aja kita oprek, seperti sebelumnya jangan lupa reset dulu lalu remove konfigurasi defaultnya.

      Setting Wlan yang ada mikrotik RB411ah
[admin@MikroTik] /interface wireless> set 0 name=wlan1 ssid=memetMetel.in frequency=2422 mode=ap-bridge band=2ghz-b/g frequency-mode=superchanel
      Menambahkan IP dari gateway
[admin@Mikrotik] /ip address> add address=192.168.1.11/24 interface=ether1
      Menambahkan IP buat client
[admin@Mikrotik] /ip address> add address=192.168.3.1/28 interface=wlan1
      Menambahkan gateway dan DNS server
[admin@Mikrotik] /ip route add gateway=192.168.1.1
[admin@Mikrotik] /ip dns set server=192.168.1.1,8.8.8.8 allow-remote-request=yes
      Maskuret ūüėõ
[admin@Mikrotik] /ip fire nat add chain=srcnat src-address=192.168.3.0/28 action=masquerade
      Membuat DHCP server biar client ga ribet-ribet masukin IP
[admin@MikroTik] /ip dhcp-server> setup
Select interface to run DHCP server on dhcp server interface: wlan1
Select network for DHCP addresses

dhcp address space: 192.168.3.0/28
Select gateway for given network

gateway for dhcp network: 192.168.3.1
Select pool of ip addresses given out by DHCP server

addresses to give out: 192.168.3.2-192.168.3.14
Select DNS servers

dns servers: 192.168.1.1,8.8.8.8
Select lease time

lease time: 3d

ketik ‘setup’ langsung ‘enter’ jangan ‘entar’.

      Edit IP pool nya
[admin@Mikrotik] /ip pool set 0 next-pool=dhcp_pool1

Sekarang kita scan dari laptop atau telepon genggam, berikut penampakan di laptop saya.
scan dari laptop
terkoneksi
IPnya

links: http://wiki.mikrotik.com/wiki/Manual:IP/DHCP_Server

Setting cepat mikrotik routerboard 750

Routerboards 750 termasuk router yang imut tapi fitur-fitur yang bisa diaplikasikan sangat banyak dari routing dasar sampai routing yang rumit. Kali ini saya mau coba share setting cepat supaya RB750 bisa terkoneksi ke internet (sebelumnya harus sudah ada koneksi ke internet). Topologinya seperti gambar berikut. Topologi
Disini saya pakai port 4 dan port 5, dimana port 4 dari ISP dan port 5 untuk klien. Pastikan mikrotik sudah direset ulang dan remove semua settingan defaultnya.

Flags: D - dynamic, X - disabled, R - running, S - slave
#     NAME                             TYPE               MTU L2MTU  MAX-L2MTU
0     ether1                           ether             1500  1600       4076
1     ether2                           ether             1500  1598       2028
2     ether3                           ether             1500  1598       2028
3  R  ether4                           ether             1500  1598       2028
4  R  ether5                           ether             1500  1598       2028

kita setting dari awal :

  1. Menambahkan IP address dari internet/ISP
  2. Menambahkan gateway
  3. Menambahkan DNS
  4. Menambahkan IP address untuk client
  5. Menambahkan NAT
  6. Cek koneksi dengan ping ke gateway dan DNS server dari mikrotik dan klien
  7. Selesai

Saya coba rinci untuk perintah di mikrotik RB750 :

  • Menambahkan IP address dari internet/ISP
[admin@mikrotik] /ip address> add address=12.34.56.78/30 interface=ether4 comment="dari internet"
[admin@mikrotik] /ip address>print
Flags: X - disabled, I - invalid, D - dynamic
# ADDRESS       NETWORK      INTERFACE
0 ;;; dari internet</code>
12.34.56.78/30          12.34.56.76             ether4
  • Menambahkan gateway
[admin@mikrotik] /ip routes>add gateway=12.34.56.77
[admin@mikrotik] /ip routes>print
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
0 A S 0.0.0.0/0 12.34.56.77 1
1 ADC 12.34.56.78/30 12.34.56.78 ether5 0
  • Menambahkan DNS server
[admin@mikrotik] /ip dns> set servers=8.8.8.8,8.8.4.4 allow-remote-request=yes 
[admin@mikrotik] /ip dns> print
                servers: 8.8.8.8,8.8.4.4
        dynamic-servers: 
  allow-remote-requests: yes
    max-udp-packet-size: 4096
             cache-size: 2048KiB
          cache-max-ttl: 1w
             cache-used: 8KiB
[admin@mikrotik]
  • Menambahkan IP address untuk client
[admin@mikrotik] /ip address> add address 192.168.1.1/27 interface=ether5 comment="untuk klient"
[admin@mikrotik] print
Flags: X - disabled, I - invalid, D - dynamic 
 #   ADDRESS            NETWORK         INTERFACE                                                                 
 0   ;;; dari internet
     12.34.56.78/30     12.34.56.76      ether4                                   
 1   ;;; untuk klient
     192.168.1.1/27     192.168.1.0      ether5
  • Menambahkan NAT
[admin@mikrotik] /ip firewall nat> add chain=srcnat src-address=192.168.1.0/27 action=masquerade
[admin@mikrotik] print
Flags: X - disabled, I - invalid, D - dynamic 
 0   chain=srcnat action=masquerade src-address=192.168.1.0/27 
  • Cek koneksi dengan ping ke gateway dan DNS server dari mikrotik dan klien

Untuk cek koneksi salah satunya dengan PING, ping ke gateway dari mikrotik dan PC kalau replay berarti settingan ip point to point kita sudah benar, tinggal cek konkesi kita ke internet dengan ping ke DNS server yang diberikan oleh ISP kita.

links : http://wiki.mikrotik.com/wiki/NAT_Tutorial

Install cacti 0.8.8a ubuntu server 12.04

Install LAMPP (web server) menggunakan tasksel

$ sudo tasksel

lalu pilih LAMPP server dan masukan password buat root mysql.

Install snmp dan rrdtool

$ sudo apt-get install snmp snmpd rrdtool

Buat database  cacti di mysql

$ mysql -u root -p Enter
password:
mysql>create database cacti;
mysql>GRANT ALL ON cacti.* TO "cacti"@"localhost" IDENTIFIED BY 'password u/ cacti';
mysql>flush privliges;
mysql>q

Download cacti 0.8.8a lalu ekstrak

$ mkdir /temp
$ cd /temp
$ wget http://www.cacti.net/downloads/cacti-0.8.8a.tar.gz $ tar xvfz cacti-0.8.8a.tar.gz

Pindahkan hasil ektraknya ke folder /var/www

$ mv cacti-0.8.8a /var/www/cacti

upload database cacti yang sudah didownload tadi ke mysql

$ cd /var/www/cacti

$ mysql -u root -p cacti < cacti.sql 

Membuat jadwal di cronjob

$ crontab -e 

masukan baris berikut :

*/5 * * * * php /var/www/cacti/poller.php > /dev/null 2>&1

Edit file config.php

$ cd /var/www/cacti
$ nano ./include/config.php /* make sure these values refect your actual database/host/user/password */
$database_type = "mysql";
$database_default = "cacti";
$database_hostname = "localhost";
$database_username = "cactiuser"; > mysql user untuk cacti
$database_password = "cactiuser"; > mysql password untuk cacti
$database_port = "3306";
$database_ssl = false;

lalu simpan Ctrl+x lalu Ctrl+y Untuk selanjutnya buka web browser arahkan ke ip cacti

http://ip_server_cacti/cacti

klik NEXT User dan password default cacti adalah ”admin” Penggantian password default terserah kita. Untuk installasi cacti sampai tahap ini sudah selesai.

Masalah yang saya jumpai setelah selesai install cacti

Setelah sekian lama menunggu pembuatan grafik, ternyata grafiknya tidak jadi-jadi. Coba jalankan perintah ini dikonsol

$ cd /var/www/cacti
$ sudo php poller.php

hasil keluarannya seperti berikut :

............ ............ Cannot adopt OID in NET-SNMP-AGENT-MIB: nsCacheEnabled ::= { nsCache 2 } Cannot adopt OID in NET-SNMP-AGENT-MIB: nsCacheDefaultTimeout ::= { nsCache 1 } Cannot adopt OID in UCD-SNMP-MIB: logMatchEntry ::= { logMatchTable 1 } Cannot adopt OID in UCD-SNMP-MIB: extEntry ::= { extTable 1 } Cannot adopt OID in NET-SNMP-AGENT-MIB: nsConfigLogging ::= { nsConfiguration 2 } Cannot adopt OID in NET-SNMP-AGENT-MIB: nsConfigDebug ::= { nsConfiguration 1 } Cannot adopt OID in NET-SNMP-EXAMPLES-MIB: netSnmpExampleString ::= { netSnmpExampleScalars 3 } Cannot adopt OID in NET-SNMP-EXAMPLES-MIB: netSnmpExampleSleeper ::= { netSnmpExampleScalars 2 } Cannot adopt OID in NET-SNMP-EXAMPLES-MIB: netSnmpExampleInteger ::= { netSnmpExampleScalars 1 } Cannot adopt OID in LM-SENSORS-MIB: lmVoltSensorsValue ::= { lmVoltSensorsEntry 3 } Cannot adopt OID in LM-SENSORS-MIB: lmVoltSensorsDevice ::= { lmVoltSensorsEntry 2 } Cannot adopt OID in LM-SENSORS-MIB: lmVoltSensorsIndex ::= { lmVoltSensorsEntry 1 } Cannot adopt OID in NET-SNMP-AGENT-MIB: nsCacheEntry ::= { nsCacheTable 1 } Cannot adopt OID in NET-SNMP-AGENT-MIB: nsDebugTokenTable ::= { nsConfigDebug 4 } Cannot adopt OID in NET-SNMP-AGENT-MIB: nsDebugDumpPdu ::= { nsConfigDebug 3 } Cannot adopt OID in NET-SNMP-AGENT-MIB: nsDebugOutputAll ::= { nsConfigDebug 2 } Cannot adopt OID in NET-SNMP-AGENT-MIB: nsDebugEnabled ::= { nsConfigDebug 1 } Cannot adopt OID in UCD-DEMO-MIB: ucdDemoPassphrase ::= { ucdDemoPublic 4 } Cannot adopt OID in UCD-DEMO-MIB: ucdDemoUserList ::= { ucdDemoPublic 3 } Cannot adopt OID in UCD-DEMO-MIB: ucdDemoPublicString ::= { ucdDemoPublic 2 } Cannot adopt OID in UCD-DEMO-MIB: ucdDemoResetKeys ::= { ucdDemoPublic 1 }
......... .........

Solusinya install paket snmp-mibs-downloader

$ sudo apt-get install snmp-mibs-downloader

Tunggu beberapa saat, lalu lihat dihalaman web system utilities > View Cacti Log File , hasilnya kira-kira seperti ini :

04/19/2013 01:19:01 PM - SYSTEM STATS: Time:0.1052 Method:spine Processes:1 Threads:1 Hosts:3 HostsPerProcess:3 DataSources:7 RRDsProcessed:2 04/19/2013 01:18:01 PM - SYSTEM STATS: Time:0.1056 Method:spine Processes:1 Threads:1 Hosts:3 HostsPerProcess:3 DataSources:7 RRDsProcessed:4 04/19/2013 01:17:01 PM - SYSTEM STATS: Time:0.1050 Method:spine Processes:1 Threads:1 Hosts:3 HostsPerProcess:3 DataSources:7 RRDsProcessed:2 04/19/2013 01:16:01 PM - SYSTEM STATS: Time:0.1054 Method:spine Processes:1 Threads:1 Hosts:3 HostsPerProcess:3 DataSources:7 RRDsProcessed:2 04/19/2013 01:15:01 PM - SYSTEM STATS: Time:0.1062 Method:spine Processes:1 Threads:1 Hosts:3 HostsPerProcess:3 DataSources:7 RRDsProcessed:5 04/19/2013 01:14:01 PM - SYSTEM STATS: Time:0.1050 Method:spine Processes:1 Threads:1 Hosts:3 HostsPerProcess:3 DataSources:7 RRDsProcessed:2 04/19/2013 01:13:01 PM - SYSTEM STATS: Time:0.1055 Method:spine Processes:1 Threads:1 Hosts:3 HostsPerProcess:3 DataSources:7 RRDsProcessed:4 04/19/2013 01:12:01 PM - SYSTEM STATS: Time:0.1051 Method:spine Processes:1 Threads:1 Hosts:3 HostsPerProcess:3 DataSources:7 RRDsProcessed:2 04/19/2013 01:11:01 PM - SYSTEM STATS: Time:0.1051 Method:spine Processes:1 Threads:1 Hosts:3 HostsPerProcess:3 DataSources:7 RRDsProcessed:2 04/19/2013 01:10:01 PM - SYSTEM STATS: Time:0.1063 Method:spine Processes:1 Threads:1 Hosts:3 HostsPerProcess:3 DataSources:7 RRDsProcessed:5 04/19/2013 01:09:01 PM - SYSTEM STATS: Time:0.1057 Method:spine Processes:1 Threads:1 Hosts:3 HostsPerProcess:3 DataSources:7 RRDsProcessed:2 04/19/2013 01:08:01 PM - SYSTEM STATS: Time:0.1055 Method:spine Processes:1 Threads:1 Hosts:3 HostsPerProcess:3 DataSources:7 RRDsProcessed:4 04/19/2013 01:07:01 PM - SYSTEM STATS: Time:0.1050 Method:spine Processes:1 Threads:1 Hosts:3 HostsPerProcess:3 DataSources:7 RRDsProcessed:2 04/19/2013 01:06:01 PM - SYSTEM STATS: Time:0.1050 Method:spine Processes:1 Threads:1 Hosts:3 HostsPerProcess:3 DataSources:7 RRDsProcessed:2 04/19/2013 01:05:01 PM - SYSTEM STATS: Time:0.1063 Method:spine Processes:1 Threads:1 Hosts:3 HostsPerProcess:3 DataSources:7 RRDsProcessed:5

Sekarang sudah bisa dilihat grafiknya muncul di menu graph.

Lain – lain

  1. Menambahkan perangkat mikrotik supaya queues bisa dibuat grapik bisa dibaca di http://forums.cacti.net/viewtopic.php?t=25349
  2. Spine sebagai type pollernya bisa dibaca di http://wmunguiam.blogspot.com/2009/01/howto-install-spine-engine-for-cacti.html . Filenya bisa di download di http://www.cacti.net/downloads/spine/ dan sesuaikan dengan versi cactinya.
  3. Error Cannot find MySQL header files under yes http://ubuntuforums.org/showthread.php?t=637973

UPDATE 19 may 2014 | ERROR

Setelah sekian lama bertahan dengan cacti versi 0.8.8a, tadi tiba-tiba mendapati error di Console -> Utilities -> View Cacti Log seperti berikut :

05/19/2014 07:45:30 PM - CMDPHP: Poller[0] ERROR: SQL Assoc Failed!, Error:'1064', SQL:"select data_input_fields.type_code, data_input_data.value from (data_input_fields,data_input_data) where data_input_fields.id=data_input_data.data_input_field_id and data_input_data.data_template_data_id= and (data_input_fields.type_code='index_type' or data_input_fields.type_code='index_value' or data_input_fields.type_code='output_type')"

dan dihalaman graph tidak muncul lagi grafik seperti biasa. Coba oprek, update system dan reboot mesin masih tidak berhasil, akhirnya coba upgrade versi ke 0.8.8b dan berhasil menghijaukan kembali halaman Console -> Utilities -> View Cacti Log.

UPDATE 15 April 2015 | cacti preview mode tidak tampil gambar

Ganti file [cacti folder]/lib/rrd.php dengan yang dari sini http://svn.cacti.net/viewvc/cacti/branches/0.8.8/lib/rrd.php?view=markup&pathrev=7418

cd [cacti folder]
mv lib/rrd.php lib/rrd.php.orig

buat file rrd.php baru

nano lib/rrd.php

Referensi

Routing

Topologi jaringan yang simple memang bridging jawabannya menurut saya, yang menghubungkan antara server dengan klien yang jauh lokasinya dengan teknologi wireless. Dari perangkat yang ‘low’ sampai dengan ‘high’ kemampuannya dalam mengirimkan paket. Tapi setelah sekian lama dengan bridging ternyata menuai banyak masalah akhir-akhir ini, hal tersebut sangat menguras pikiran sementara data-data di klien sudah semakin menumpuk untuk diupload. Ternyata bridging tidak bisa saya atasi.

Teringat perkataan saudara sekaligus teman bahwa menghubungkan beberapa perangkat dalam satu jaringan bisa dengan routing juga, seperti kata pepatah ‘banyak jalan menuju roma’. Bermodalkan beberapa perangkat dan sedikit pengetahuan tentang IP subneting akhirnya melakukan juga beberapa oprekan, kebetulan disini ada beberapa perangkat wireless mikrotik yang nganggur. Berikut hasilnya.

routing test3

routing test 1

Routingan ini saya terapkan juga pada jaringan dengan perangkat wireless Ubnt Rocket M5. Dengan dasar pada settingan setiap perangkat wireless, bridgenya tidak dipakai begitupun dengan WDS-mode di mikrotik saya disable. Jadi diperangkat pemancar saya setting bridge atau ap-bridge dan di kliennya saya setting station.